aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSergey Bugaev <bugaevc@gmail.com>2024-03-27 19:18:34 +0300
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2024-03-27 19:51:06 +0100
commit62e3c40ebb090e24c70a38c13957f5a02857383e (patch)
tree0c866ffc3e0222486ae71c0bbce8de04604b1b4a /Makefile.am
parent6036cc18e6a67a15e2b6d9dff37d05b411c199c3 (diff)
downloadgnumach-62e3c40ebb090e24c70a38c13957f5a02857383e.tar.gz
gnumach-62e3c40ebb090e24c70a38c13957f5a02857383e.tar.bz2
gnumach-62e3c40ebb090e24c70a38c13957f5a02857383e.zip
Make -fno-PIE etc. architecture-dependent
There might be good reasons why Mach on x86 shouldn't be built as PIC/ PIE, but there are also very good reasons to support PIE on other architectures. Potentially implementing KASLR is one such reason; but also the Linux AArch64 boot protocol (that the AArch64 port will use for booting) lets the bootloader load the kernel image at any address, which makes PIC pretty much required. Message-ID: <20240327161841.95685-11-bugaevc@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ad38249b..357e8470 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,10 +79,6 @@ AM_CFLAGS += \
-fno-stack-protector
endif
-# We do not support or need position-independent
-AM_CFLAGS += \
- -no-pie -fno-PIE -fno-pie -fno-pic
-
# This must be the same size as port names, see e.g. ipc/ipc_entry.c
AM_CFLAGS += -DRDXTREE_KEY_32