aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlavio Cruz <flaviocruz@gmail.com>2024-07-10 17:04:40 +0100
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2024-07-10 22:34:25 +0200
commit97c589d0919cbb5b11156fa973b803fca3275af8 (patch)
tree9821ec06759017698234013aa68929adec914397 /Makefile.am
parentcb9ba488e47f4f836ed85841d66e3930b1f6e10f (diff)
downloadgnumach-97c589d0919cbb5b11156fa973b803fca3275af8.tar.gz
gnumach-97c589d0919cbb5b11156fa973b803fca3275af8.tar.bz2
gnumach-97c589d0919cbb5b11156fa973b803fca3275af8.zip
Ensure we always pass -ffreestanding -nostdlib even if CFLAGS are overridden.
Message-ID: <4cea36qrjeo7tkklmqcwgkrxstxiqykdofha65zxmpni2o6lp3@2offokab6fvn>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 357e8470..837d602e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,6 +72,11 @@ AM_CFLAGS += \
AM_CFLAGS += \
-fno-strict-aliasing
+# We use a freestanding environment.
+AM_CFLAGS += \
+ -ffreestanding \
+ -nostdlib
+
# The smashing stack protector might be enabled by default, but might emit
# unsuitable code.
if disable_smashing_stack_protector