aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlavio Cruz <flaviocruz@gmail.com>2023-01-21 21:42:12 -0500
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2023-01-24 02:36:13 +0100
commit7d6e296b4256c8c1002f053a9aeefc077a0363b3 (patch)
treef3d01da05bb29a38460e1bebc8b2de3dff9e5414 /configure.ac
parente3a433153e237ce7fc5caf51edd602500e256156 (diff)
downloadgnumach-7d6e296b4256c8c1002f053a9aeefc077a0363b3.tar.gz
gnumach-7d6e296b4256c8c1002f053a9aeefc077a0363b3.tar.bz2
gnumach-7d6e296b4256c8c1002f053a9aeefc077a0363b3.zip
Use -O2 -g by default when compiling
After d5e5dd3401ea0d0475aa830c2171be5b8a72f4fa we can configure and make gnumach without glibc, however it no longer used -O2 -g in CFLAGS by default. This reverts that behavior. Message-Id: <Y8yihABKwOjqi4y3@jupiter.tail36e24.ts.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f10b5d5..3665d47a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,10 @@ AC_INIT([AC_PACKAGE_NAME], [AC_PACKAGE_VERSION], [AC_PACKAGE_BUGREPORT],
[AC_PACKAGE_TARNAME])
AC_CONFIG_SRCDIR([kern/ipc_kobject.c])
+if test -z "${CFLAGS+set}"; then
+ # Use these CFLAGS by default if nothing is set.
+ CFLAGS="-g -O2"
+fi
# We don't need glibc to compile gnumach.
CFLAGS="$CFLAGS -ffreestanding -nostdlib"