aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Bugaev <bugaevc@gmail.com>2024-04-15 12:01:42 +0300
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2024-04-16 09:37:03 +0900
commitb23e7718dd9942b27edfac9aee05f737d0e6922e (patch)
tree7ae65de44b1a513430163342f229b0aa4b541e52 /configure.ac
parentb792f1eb08e34db89ac200a86ea7e6859a6b0668 (diff)
downloadgnumach-b23e7718dd9942b27edfac9aee05f737d0e6922e.tar.gz
gnumach-b23e7718dd9942b27edfac9aee05f737d0e6922e.tar.bz2
gnumach-b23e7718dd9942b27edfac9aee05f737d0e6922e.zip
aarch64: Add the basics
This adds "aarch64" host support to the build system, along with some uninteresting installed headers. The empty aarch64/aarch64/ast.h header is also added to create the aarch64/aarch64/ directory (due to Git peculiarity). With this, it should be possible to run 'configure --host=aarch64-gnu' and 'make install-data' successfully. Message-ID: <20240415090149.38358-3-bugaevc@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69f75cf2..bf74b88e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,8 @@ case $host_platform:$host_cpu in
[host_platform=at;;
at:i?86 | xen:i?86 | at:x86_64 | xen:x86_64)
:;;
+ *:aarch64)
+ ;;
*)]
AC_MSG_ERROR([unsupported combination of cpu type `$host_cpu' and platform
`$host_platform'.])[;;
@@ -173,6 +175,9 @@ m4_include([i386/configfrag.ac])
# x86_64
m4_include([x86_64/configfrag.ac])
+# aarch64
+m4_include([aarch64/configfrag.ac])
+
# General options.
m4_include([configfrag.ac])