aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlavio Cruz <flaviocruz@gmail.com>2023-01-09 22:16:43 -0500
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2023-01-10 22:09:04 +0100
commitd5e5dd3401ea0d0475aa830c2171be5b8a72f4fa (patch)
tree9bb1928b9d395eb498bfa5319ffffa7882452794 /configure.ac
parent80a022e8e7738e2c616ac793f53c6b5005300101 (diff)
downloadgnumach-d5e5dd3401ea0d0475aa830c2171be5b8a72f4fa.tar.gz
gnumach-d5e5dd3401ea0d0475aa830c2171be5b8a72f4fa.tar.bz2
gnumach-d5e5dd3401ea0d0475aa830c2171be5b8a72f4fa.zip
Update configure.ac so that we don't need glibc when running ./configure.
For x86_64-pc-gnu we still do not have a working glibc so ./configure will fail under a freestanding environment. We force ./configure to avoid running compiled C programs as a test which it is not needed when compiling a kernel. Message-Id: <Y7zYm44O0CNayuAe@jupiter.tail36e24.ts.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3aaa935c..8f10b5d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,9 @@ AC_INIT([AC_PACKAGE_NAME], [AC_PACKAGE_VERSION], [AC_PACKAGE_BUGREPORT],
[AC_PACKAGE_TARNAME])
AC_CONFIG_SRCDIR([kern/ipc_kobject.c])
+# We don't need glibc to compile gnumach.
+CFLAGS="$CFLAGS -ffreestanding -nostdlib"
+
AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE(
@@ -79,7 +82,12 @@ AC_SUBST([systype])
#
AC_PROG_AWK
+# Temporarily force cross compiling mode to make sure the configure script
+# does not try to run compiled binaries.
+save_cross_compiling=$cross_compiling
+cross_compiling=yes
AM_PROG_AS
+cross_compiling=$save_cross_compiling
AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL