aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 357e8470..837d602e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,6 +72,11 @@ AM_CFLAGS += \
AM_CFLAGS += \
-fno-strict-aliasing
+# We use a freestanding environment.
+AM_CFLAGS += \
+ -ffreestanding \
+ -nostdlib
+
# The smashing stack protector might be enabled by default, but might emit
# unsuitable code.
if disable_smashing_stack_protector