aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d4daa932..42dfcd40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,7 +55,10 @@ AC_ARG_ENABLE([platform],
case $host_platform:$host_cpu in
default:i?86)
host_platform=at;;
- at:i?86 | xen:i?86)
+ default:x86_64)]
+ AC_MSG_WARN([Platform set to Xen by default, this can not boot on non-Xen systems, you currently need a 32bit build for that.])
+ [host_platform=xen;;
+ at:i?86 | xen:i?86 | xen:x86_64)
:;;
*)]
AC_MSG_ERROR([unsupported combination of cpu type `$host_cpu' and platform
@@ -139,6 +142,9 @@ m4_include([xen/configfrag.ac])
# ix86.
m4_include([i386/configfrag.ac])
+# x86_64
+m4_include([x86_64/configfrag.ac])
+
# General options.
m4_include([configfrag.ac])