aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 2546be9b..f42f6e6e 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.7 1996/08/13 18:10:06 thomas Exp $])
+AC_REVISION([$Id: configure.in,v 1.8 1996/09/05 14:14:01 thomas Exp $])
AC_PREREQ(2.4) dnl Minimum Autoconf version required.
AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
@@ -11,6 +11,14 @@ gnu*) ;;
*) AC_MSG_ERROR([sorry, this is the gnu os, not $host_os]) ;;
esac
+case "$host_cpu" in
+i[[3456]]86)
+ asm_syntax=i386
+ ;;
+*) AC_MSG_ERROR([unspported CPU type]) ;;
+esac
+AC_SUBST(asm_syntax)
+
AC_PROG_INSTALL
AC_CHECK_TOOL(CC, gcc)