aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSebastian Ramacher <sramacher@debian.org>2024-12-29 12:50:37 +0000
committerSebastian Ramacher <sramacher@debian.org>2024-12-29 12:50:37 +0000
commit873c687c09e0a1a78a8f3601d31330ad1897e484 (patch)
treeff2fa2e2d27b55c002a6d46d50aab2c66e0bf21a /debian
parent395b1f6877fbc2666383f3428f17400c35aa52a4 (diff)
parentb9ae809f200982119d16ec9613f3db95eca923b9 (diff)
downloadlibgav1-873c687c09e0a1a78a8f3601d31330ad1897e484.tar.gz
libgav1-873c687c09e0a1a78a8f3601d31330ad1897e484.tar.bz2
libgav1-873c687c09e0a1a78a8f3601d31330ad1897e484.zip
Merge branch 'master' into 'scrub-obsolete'
# Conflicts: # debian/changelog
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/control4
-rw-r--r--debian/patches/0001-Unbundle-abseil.patch4
-rw-r--r--debian/patches/0002-Use-system-googletest.patch39
-rw-r--r--debian/patches/0003-Use-C-14.patch21
-rw-r--r--debian/patches/0004-Temporarily-disable-CPU-test.patch44
-rw-r--r--debian/patches/series3
7 files changed, 133 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 3d1ce75..489e885 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,30 @@
-libgav1 (0.18.0-2) UNRELEASED; urgency=medium
+libgav1 (0.19.0-3) UNRELEASED; urgency=medium
* Remove constraints unnecessary since buster (oldstable):
+ Build-Depends: Drop versioned constraint on cmake (>= 3.7.1).
-- Debian Janitor <janitor@jelmer.uk> Sat, 21 Jan 2023 01:43:08 -0000
+libgav1 (0.19.0-2) unstable; urgency=medium
+
+ * Team upload
+ * Upload to unstable (Closes: #1068180)
+ * debian/patches: Temporarily disable cpu test
+
+ -- Sebastian Ramacher <sramacher@debian.org> Mon, 01 Apr 2024 15:14:00 +0200
+
+libgav1 (0.19.0-1~exp1) experimental; urgency=medium
+
+ * Team upload.
+ * New upstream release.
+ * debian/patches/0001-Unbundle-abseil.patch: Refresh the patch.
+ * debian/patches/0002-Use-system-googletest.patch: Try to enable
+ googletest.
+ * debian/patches/0003-Use-C-14.patch: Force C++14 standard to avoid
+ FTBFS with googletest.
+
+ -- Boyuan Yang <byang@debian.org> Mon, 27 Nov 2023 23:17:46 -0500
+
libgav1 (0.18.0-1) unstable; urgency=medium
* Upload to unstable.
diff --git a/debian/control b/debian/control
index 5368965..f71a262 100644
--- a/debian/control
+++ b/debian/control
@@ -4,11 +4,13 @@ Priority: optional
Maintainer: Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Uploaders: qinxialei <xialeiqin@gmail.com>
Build-Depends:
+ architecture-is-little-endian,
debhelper-compat (= 13),
cmake,
libabsl-dev,
pkg-kde-tools,
-Standards-Version: 4.6.1
+ googletest <!nocheck>,
+Standards-Version: 4.6.2
Homepage: https://chromium.googlesource.com/codecs/libgav1/
Vcs-Browser: https://salsa.debian.org/multimedia-team/libgav1
Vcs-Git: https://salsa.debian.org/multimedia-team/libgav1.git
diff --git a/debian/patches/0001-Unbundle-abseil.patch b/debian/patches/0001-Unbundle-abseil.patch
index 67a8357..1395830 100644
--- a/debian/patches/0001-Unbundle-abseil.patch
+++ b/debian/patches/0001-Unbundle-abseil.patch
@@ -7,7 +7,7 @@ Subject: Unbundle abseil
1 file changed, 3 insertions(+), 18 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 52b1b32..d5e8f95 100644
+index 73f27a1..e9bb9b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,7 +116,6 @@ if(LIBGAV1_VERBOSE)
@@ -35,7 +35,7 @@ index 52b1b32..d5e8f95 100644
- " examples & tests and libgav1 when LIBGAV1_THREADPOOL_USE_STD_MUTEX is"
- " not defined. To continue, download the Abseil repository to"
- " third_party/abseil-cpp:\n git \\\n -C ${libgav1_root} \\\n"
-- " clone \\\n"
+- " clone -b 20220623.0 --depth 1 \\\n"
- " https://github.com/abseil/abseil-cpp.git third_party/abseil-cpp")
- endif()
-endif()
diff --git a/debian/patches/0002-Use-system-googletest.patch b/debian/patches/0002-Use-system-googletest.patch
new file mode 100644
index 0000000..bef8377
--- /dev/null
+++ b/debian/patches/0002-Use-system-googletest.patch
@@ -0,0 +1,39 @@
+From: Boyuan Yang <byang@debian.org>
+Date: Mon, 27 Nov 2023 23:03:28 -0500
+Subject: Use system googletest
+
+---
+ cmake/libgav1_build_definitions.cmake | 6 +++---
+ tests/libgav1_tests.cmake | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/cmake/libgav1_build_definitions.cmake b/cmake/libgav1_build_definitions.cmake
+index 1465679..16ddd4a 100644
+--- a/cmake/libgav1_build_definitions.cmake
++++ b/cmake/libgav1_build_definitions.cmake
+@@ -43,9 +43,9 @@ macro(libgav1_set_build_definitions)
+ list(APPEND libgav1_include_paths "${libgav1_root}" "${libgav1_root}/src"
+ "${libgav1_build}" "${libgav1_root}/third_party/abseil-cpp")
+ list(APPEND libgav1_gtest_include_paths
+- "third_party/googletest/googlemock/include"
+- "third_party/googletest/googletest/include"
+- "third_party/googletest/googletest")
++ "/usr/src/googletest/googlemock/include"
++ "/usr/src/googletest/googletest/include"
++ "/usr/src/googletest/googletest")
+ list(APPEND libgav1_test_include_paths ${libgav1_include_paths}
+ ${libgav1_gtest_include_paths})
+ list(APPEND libgav1_defines "LIBGAV1_CMAKE=1"
+diff --git a/tests/libgav1_tests.cmake b/tests/libgav1_tests.cmake
+index 95f6361..209054b 100644
+--- a/tests/libgav1_tests.cmake
++++ b/tests/libgav1_tests.cmake
+@@ -17,7 +17,7 @@ if(LIBGAV1_LIBGAV1_TESTS_CMAKE_)
+ endif() # LIBGAV1_LIBGAV1_TESTS_CMAKE_
+ set(LIBGAV1_LIBGAV1_TESTS_CMAKE_ 1)
+
+-set(libgav1_googletest "${libgav1_root}/third_party/googletest")
++set(libgav1_googletest "/usr/src/googletest/")
+ if(NOT LIBGAV1_ENABLE_TESTS OR NOT EXISTS "${libgav1_googletest}")
+ macro(libgav1_add_tests_targets)
+
diff --git a/debian/patches/0003-Use-C-14.patch b/debian/patches/0003-Use-C-14.patch
new file mode 100644
index 0000000..a4f4e10
--- /dev/null
+++ b/debian/patches/0003-Use-C-14.patch
@@ -0,0 +1,21 @@
+From: Boyuan Yang <byang@debian.org>
+Date: Mon, 27 Nov 2023 23:08:49 -0500
+Subject: Use C++14
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e9bb9b0..abc3b41 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -16,7 +16,7 @@
+ cmake_minimum_required(VERSION 3.7.1 FATAL_ERROR)
+
+ # libgav1 requires C++11.
+-set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD 14)
+ set(ABSL_CXX_STANDARD 11)
+ # libgav1 requires C99.
+ set(CMAKE_C_STANDARD 99)
diff --git a/debian/patches/0004-Temporarily-disable-CPU-test.patch b/debian/patches/0004-Temporarily-disable-CPU-test.patch
new file mode 100644
index 0000000..269d016
--- /dev/null
+++ b/debian/patches/0004-Temporarily-disable-CPU-test.patch
@@ -0,0 +1,44 @@
+From: Sebastian Ramacher <sramacher@debian.org>
+Date: Mon, 1 Apr 2024 15:13:03 +0200
+Subject: Temporarily disable CPU test
+
+Parsing of the max CPU frequency is broken on ARM.
+---
+ tests/libgav1_tests.cmake | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git a/tests/libgav1_tests.cmake b/tests/libgav1_tests.cmake
+index 209054b..76eece7 100644
+--- a/tests/libgav1_tests.cmake
++++ b/tests/libgav1_tests.cmake
+@@ -99,7 +99,6 @@ list(APPEND libgav1_common_sse4_test_sources
+ "${libgav1_source}/dsp/x86/common_sse4_test.h")
+ list(APPEND libgav1_convolve_test_sources
+ "${libgav1_source}/dsp/convolve_test.cc")
+-list(APPEND libgav1_cpu_test_sources "${libgav1_source}/utils/cpu_test.cc")
+ list(APPEND libgav1_c_decoder_test_sources
+ "${libgav1_source}/c_decoder_test.c"
+ "${libgav1_source}/decoder_test_data.h")
+@@ -339,22 +338,6 @@ macro(libgav1_add_tests_targets)
+ libgav1_gtest
+ libgav1_gtest_main)
+
+- libgav1_add_executable(TEST
+- NAME
+- cpu_test
+- SOURCES
+- ${libgav1_cpu_test_sources}
+- DEFINES
+- ${libgav1_defines}
+- INCLUDES
+- ${libgav1_test_include_paths}
+- OBJLIB_DEPS
+- libgav1_utils
+- LIB_DEPS
+- ${libgav1_common_test_absl_deps}
+- libgav1_gtest
+- libgav1_gtest_main)
+-
+ libgav1_add_executable(TEST
+ NAME
+ entropy_decoder_test
diff --git a/debian/patches/series b/debian/patches/series
index b92502a..d091eb0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,4 @@
0001-Unbundle-abseil.patch
+0002-Use-system-googletest.patch
+0003-Use-C-14.patch
+0004-Temporarily-disable-CPU-test.patch