aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/Unbundling-abseil.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/Unbundling-abseil.patch')
-rw-r--r--debian/patches/Unbundling-abseil.patch22
1 files changed, 16 insertions, 6 deletions
diff --git a/debian/patches/Unbundling-abseil.patch b/debian/patches/Unbundling-abseil.patch
index c33dcbe..83672d4 100644
--- a/debian/patches/Unbundling-abseil.patch
+++ b/debian/patches/Unbundling-abseil.patch
@@ -1,7 +1,7 @@
Unbundling abseil
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -97,7 +97,6 @@
+@@ -100,7 +100,6 @@
libgav1_dump_options()
endif()
@@ -9,12 +9,22 @@ Unbundling abseil
set(libgav1_gtest_build "${libgav1_build}/gtest")
# Compiler/linker flags must be lists, but come in from the environment as
-@@ -109,8 +108,8 @@
- separate_arguments(LIBGAV1_EXE_LINKER_FLAGS)
- endif()
+@@ -115,18 +114,8 @@
+ # Set test-only flags based on LIBGAV1_CXX_FLAGS.
+ libgav1_set_test_flags()
--add_subdirectory("${libgav1_root}/third_party/abseil-cpp"
-- "${libgav1_abseil_build}" EXCLUDE_FROM_ALL)
+-set(libgav1_abseil "${libgav1_root}/third_party/abseil-cpp")
+-if(NOT EXISTS "${libgav1_abseil}")
+- message(
+- FATAL_ERROR
+- "Abseil not found. This dependency is required by the"
+- " examples & tests and libgav1 when LIBGAV1_THREADPOOL_USE_STD_MUTEX is"
+- " not defined. To continue, download the Abseil repository to"
+- " third_party/abseil-cpp:\n git \\\n -C ${libgav1_root} \\\n"
+- " clone \\\n"
+- " https://github.com/abseil/abseil-cpp.git third_party/abseil-cpp")
+-endif()
+-add_subdirectory("${libgav1_abseil}" "${libgav1_abseil_build}" EXCLUDE_FROM_ALL)
+set(absl "/usr/lib/*/cmake/absl")
+find_package(absl REQUIRED)