aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 09ea32f..6366686 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,11 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
CXXFLAGS += $(CPPFLAGS)
+# try to fix FTBFS on mipsel
+ifneq (,$(filter $(DEB_HOST_ARCH), armel m68k mips mipsel powerpc powerpcspe sh4))
+ export DEB_LDFLAGS_MAINT_APPEND=-latomic
+endif
+
%:
dh $@