aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlavio Cruz <flaviocruz@gmail.com>2016-04-18 19:48:50 -0400
committerJustus Winter <justus@gnupg.org>2016-04-19 12:04:46 +0200
commit36457093278a06752c44c10bb98e4b1eeab3f792 (patch)
treec2e25ebdc3d3832c1b76eadac88c88db9c4d74c0 /Makefile.am
parent6dfd373070a059f3d79c663b6fb98bd17b2321d6 (diff)
downloadmig-36457093278a06752c44c10bb98e4b1eeab3f792.tar.gz
mig-36457093278a06752c44c10bb98e4b1eeab3f792.tar.bz2
mig-36457093278a06752c44c10bb98e4b1eeab3f792.zip
Simple testsuite for MIG.
This includes a set of valid and invalid definition files that MIG will try to process. For valid definitions, GCC will compile the stubs to check if valid C code was generated. * configure.ac: Add new test Makefiles. * Makefile.am: Add SUBDIRS. * tests/Makeconf.am: Automake definitions shared by all test subdirectories. * tests/test_lib.sh: Library of functions shared by all test drivers. * tests/good/run_good_test.sh: Script to run valid definition files. * tests/good/Makefile.am: New file. * tests/bad/Makefile.am: New file. * tests/generate-only/Makefile.am: New file. * tests/bad/run_bad_test.sh: Script to run invalid definition files. * tests/generate-only/run_generate_only.sh: Script to run valid definition files that should be generated only. * tests/includes/*.h: Test header files that are included by test stubs. * tests/good/*.defs: Valid definition files where generated stubs can be compiled. * tests/generate_only/*.defs: Valid definition files that can be generated but no compilation should be attempted. * tests/bad/*.defs: Definition files with problems that should be detected by MIG.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 65737be..5d924da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,8 @@ EXTRA_DIST = gensym.awk cpu.sym
CLEANFILES = cpu.h *.sym[co] lexxer.c parser.c parser.h
+SUBDIRS = tests
+
AWK_V = $(AWK_V_$(V))
AWK_V_ = $(AWK_V_$(AM_DEFAULT_VERBOSITY))
AWK_V_0 = @echo " AWK $@";