aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlavio Cruz <flaviocruz@gmail.com>2016-04-18 19:48:50 -0400
committerJustus Winter <justus@gnupg.org>2016-04-19 12:04:46 +0200
commit36457093278a06752c44c10bb98e4b1eeab3f792 (patch)
treec2e25ebdc3d3832c1b76eadac88c88db9c4d74c0 /configure.ac
parent6dfd373070a059f3d79c663b6fb98bd17b2321d6 (diff)
downloadmig-36457093278a06752c44c10bb98e4b1eeab3f792.tar.gz
mig-36457093278a06752c44c10bb98e4b1eeab3f792.tar.bz2
mig-36457093278a06752c44c10bb98e4b1eeab3f792.zip
Simple testsuite for MIG.
This includes a set of valid and invalid definition files that MIG will try to process. For valid definitions, GCC will compile the stubs to check if valid C code was generated. * configure.ac: Add new test Makefiles. * Makefile.am: Add SUBDIRS. * tests/Makeconf.am: Automake definitions shared by all test subdirectories. * tests/test_lib.sh: Library of functions shared by all test drivers. * tests/good/run_good_test.sh: Script to run valid definition files. * tests/good/Makefile.am: New file. * tests/bad/Makefile.am: New file. * tests/generate-only/Makefile.am: New file. * tests/bad/run_bad_test.sh: Script to run invalid definition files. * tests/generate-only/run_generate_only.sh: Script to run valid definition files that should be generated only. * tests/includes/*.h: Test header files that are included by test stubs. * tests/good/*.defs: Valid definition files where generated stubs can be compiled. * tests/generate_only/*.defs: Valid definition files that can be generated but no compilation should be attempted. * tests/bad/*.defs: Definition files with problems that should be detected by MIG.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6ffbeda..897d11c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,4 +59,7 @@ AC_SUBST([MIGCOM])
[MIG=`echo mig | sed "$program_transform_name"`]
AC_SUBST([MIG])
-AC_OUTPUT([Makefile mig])
+AC_OUTPUT([Makefile mig tests/Makefile \
+ tests/good/Makefile \
+ tests/generate-only/Makefile \
+ tests/bad/Makefile])