aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index efd542a..37bf432 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,12 @@ dnl Checks for programs.
AC_PROG_CC
AC_PROG_CPP
AC_PROG_YACC
+
+yacc_is_bison=`yacc --version | head -n 1 | cut '-d ' -f1`
+[if [ x"$yacc_is_bison" != x"bison" ]; then ]
+ AC_MSG_ERROR([yacc is not provided by bison, check your alternative conf or your packages])
+[fi]
+
AM_PROG_LEX
AC_PROG_AWK
AC_PROG_INSTALL