aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2020-01-25 11:11:18 +0100
committerTomáš Mráz <t8m@users.noreply.github.com>2020-01-27 09:47:25 +0100
commit4dd9b97b762cc73816cb867d49c9d0d0b91d642c (patch)
tree421c9b1706032d77afba68741c5a756ac4b44286 /configure.ac
parentdf86351adfbe6a5dc7a68dce1074403f97fd1046 (diff)
downloadpam-4dd9b97b762cc73816cb867d49c9d0d0b91d642c.tar.gz
pam-4dd9b97b762cc73816cb867d49c9d0d0b91d642c.tar.bz2
pam-4dd9b97b762cc73816cb867d49c9d0d0b91d642c.zip
configure.ac: add --enable-doc option
Allow the user to disable documentation through --disable-doc (enabled by default), this is especially useful when cross-compiling for embedded targets Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a124b274..90818683 100644
--- a/configure.ac
+++ b/configure.ac
@@ -249,6 +249,11 @@ dnl
dnl options and defaults
dnl
+AC_ARG_ENABLE([doc],
+ AS_HELP_STRING([--disable-doc],[Do not generate or install documentation]),
+ WITH_DOC=$enableval, WITH_DOC=yes)
+AM_CONDITIONAL([HAVE_DOC], [test "x$WITH_DOC" = "xyes"])
+
AC_ARG_ENABLE([prelude],
AS_HELP_STRING([--disable-prelude],[do not use prelude]),
WITH_PRELUDE=$enableval, WITH_PRELUDE=yes)
@@ -606,7 +611,7 @@ fi
AC_PATH_PROG([FO2PDF], [fop])
-AM_CONDITIONAL(ENABLE_REGENERATE_MAN, test x$enable_docu != xno)
+AM_CONDITIONAL(ENABLE_REGENERATE_MAN, test x$enable_docu != xno -a x$enable_doc != xno)
AM_CONDITIONAL(ENABLE_GENERATE_PDF, test ! -z "$FO2PDF")