aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2005-07-20 14:52:38 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2005-07-20 14:52:38 +0000
commit3304eb34c14c7f369c1ace0f39c3df47724caf54 (patch)
tree05475d811bae41022e65af27b1b2ffebee026c1e /configure.in
parent6db0f946028a72a4551c2967cbfe9c1e3a82daa8 (diff)
downloadpam-3304eb34c14c7f369c1ace0f39c3df47724caf54.tar.gz
pam-3304eb34c14c7f369c1ace0f39c3df47724caf54.tar.bz2
pam-3304eb34c14c7f369c1ace0f39c3df47724caf54.zip
Relevant BUGIDs: none
Purpose of commit: new feature Commit summary: --------------- Mark message strings for translation
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 59c90a98..de6074da 100644
--- a/configure.in
+++ b/configure.in
@@ -71,7 +71,7 @@ AC_ARG_ENABLE(memory-debug,
WITH_MEMORY_DEBUG=yes ; AC_DEFINE([MEMORY_DEBUG],,
[Every malloc etc. call will be tracked]) , WITH_MEMORY_DEBUG=no)
AC_SUBST(WITH_MEMORY_DEBUG)
-AH_VERBATIM([_MEMORY_DEBUG],
+AH_VERBATIM([_MEMORY_DEBUG],
[#ifdef MEMORY_DEBUG
/*
* this is basically a hack - we need to include a semiarbitrary
@@ -474,5 +474,15 @@ fi
AC_SUBST(PSER)
AC_SUBST(PS2PDF)
+AH_VERBATIM([_ENABLE_NLS],
+[#ifdef ENABLE_NLS
+#include <libintl.h>
+#define _(msgid) dgettext("Linux-PAM", msgid)
+#define N_(msgid) msgid
+#else
+#define _(msgid) (msgid)
+#define N_(msgid) msgid
+#endif /* ENABLE_NLS */])
+
dnl Files to be created from when we run configure
AC_OUTPUT(Make.Rules)