aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-11-26 03:04:46 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-11-26 03:04:46 +0000
commit6d8f508fe9bed97a12d8f2a8dd01a413d7a60560 (patch)
tree68937571edf317260b842d2e5d169c9de3abe786 /configure.in
parentd0ae8d409e9e7de2c714197251c4c005fe7d7ad4 (diff)
downloadpam-6d8f508fe9bed97a12d8f2a8dd01a413d7a60560.tar.gz
pam-6d8f508fe9bed97a12d8f2a8dd01a413d7a60560.tar.bz2
pam-6d8f508fe9bed97a12d8f2a8dd01a413d7a60560.zip
Relevant BUGIDs: 485454
Purpose of commit: revive feature Commit summary: --------------- malloc et al. debugging was not supported by the new autoconf setup, this commit rectifies that. It also adds a couple of header file inclusions that seem to be needed with recent glibc headers.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0f5b8d89..da06576d 100644
--- a/configure.in
+++ b/configure.in
@@ -69,10 +69,15 @@ dnl
dnl lots of debugging information goes to /tmp/pam-debug.log
AC_ARG_ENABLE(debug,
-[ --enable-debug qspecify you are building with debugging on],
+[ --enable-debug specify you are building with debugging on],
WITH_DEBUG=yes ; AC_DEFINE(DEBUG) , WITH_DEBUG=no)
AC_SUBST(WITH_DEBUG)
+AC_ARG_ENABLE(memory-debug,
+[ --enable-memory-debug specify you want every malloc etc. call tracked],
+ WITH_MEMORY_DEBUG=yes ; AC_DEFINE(MEMORY_DEBUG) , WITH_MEMORY_DEBUG=no)
+AC_SUBST(WITH_MEMORY_DEBUG)
+
dnl build specially named libraries (for debugging purposes)
AC_ARG_ENABLE(libdebug,
[ --enable-libdebug specify you are building debugging libraries],