aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2010-08-26 13:49:33 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2010-08-26 13:49:33 +0000
commitc2cc00028b79adcbe9ed4b26f6d6c380fb4bb07b (patch)
tree9b683bdd44bece56976d8455c6d77fda4f15ddd8 /configure.in
parentfa29cc2697e1627650eeedf1ba300ad7377e11c3 (diff)
downloadpam-c2cc00028b79adcbe9ed4b26f6d6c380fb4bb07b.tar.gz
pam-c2cc00028b79adcbe9ed4b26f6d6c380fb4bb07b.tar.bz2
pam-c2cc00028b79adcbe9ed4b26f6d6c380fb4bb07b.zip
Relevant BUGIDs: #2315432, debian#284854#42.
Purpose of commit: bugfix Commit summary: --------------- 2010-08-26 Thorsten Kukuk <kukuk@thkukuk.de> * doc/specs/Makefile.am: Use CC_FOR_BUILD as compiler (cross compile support). * configure.in: Check for host compiler if cross compiling. Bug #2315432, debian#284854#42.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 87bd5680..cb827112 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT
AC_CONFIG_SRCDIR([conf/pam_conv1/pam_conv_y.y])
-AM_INIT_AUTOMAKE("Linux-PAM", 1.1.1)
+AM_INIT_AUTOMAKE("Linux-PAM", 1.1.1.91)
AC_PREREQ(2.61)
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -86,6 +86,12 @@ AM_PROG_CC_C_O
PAM_LD_AS_NEEDED
PAM_LD_O1
+if test x"$cross_compiling" = xyes; then
+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
+else
+ CC_FOR_BUILD="$CC"
+fi
+
dnl Largefile support
AC_SYS_LARGEFILE