aboutsummaryrefslogtreecommitdiff
path: root/doc/mwg/Makefile.am
diff options
context:
space:
mode:
authorStefan Schubert <schubi@suse.de>2022-10-25 16:29:41 +0200
committerThorsten Kukuk <5908016+thkukuk@users.noreply.github.com>2022-12-16 10:31:37 +0100
commitcf2fc5ff7b4a8555fda2a5ebe5f6ab0e45c22996 (patch)
tree28c25df584fc32ba8f02af48c249c987be91e9ac /doc/mwg/Makefile.am
parent6135c45347b6173e305fda66eef138bde693b795 (diff)
downloadpam-cf2fc5ff7b4a8555fda2a5ebe5f6ab0e45c22996.tar.gz
pam-cf2fc5ff7b4a8555fda2a5ebe5f6ab0e45c22996.tar.bz2
pam-cf2fc5ff7b4a8555fda2a5ebe5f6ab0e45c22996.zip
doc: Update PAM documentation from DockBook 4 to DocBook 5
Changed files -------------- Make.xml.rules.in: - Using RNG file instead of DTD file for checking XML files. - Taking the correct stylesheet for README files. doc/sag/Makefile.am, doc/adg/Makefile.am, doc/mwg/Makefile.am: - Using RNG file instead of DTD file for checking XML files. configure.ac: - Adding a new option for selecting RNG check file (-enable-docbook-rng) - Switching stylesheets to docbook 5 - Checking DocBook 5 environment instead of DocBook 4 environment *.xml: Update from DockBook 4 to DocBook 5
Diffstat (limited to 'doc/mwg/Makefile.am')
-rw-r--r--doc/mwg/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/doc/mwg/Makefile.am b/doc/mwg/Makefile.am
index 688e6cb3..340249c6 100644
--- a/doc/mwg/Makefile.am
+++ b/doc/mwg/Makefile.am
@@ -16,7 +16,7 @@ all: Linux-PAM_MWG.txt html/Linux-PAM_MWG.html Linux-PAM_MWG.pdf
Linux-PAM_MWG.pdf: $(XMLS) $(DEP_XMLS)
if ENABLE_GENERATE_PDF
- $(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
+ $(XMLLINT) --nonet --xinclude --relaxng $(DOCBOOK_RNG) --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
@@ -28,7 +28,7 @@ else
endif
Linux-PAM_MWG.txt: $(XMLS) $(DEP_XMLS)
- $(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
+ $(XMLLINT) --nonet --xinclude --relaxng $(DOCBOOK_RNG) --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
@@ -37,7 +37,7 @@ Linux-PAM_MWG.txt: $(XMLS) $(DEP_XMLS)
html/Linux-PAM_MWG.html: $(XMLS) $(DEP_XMLS)
@test -d html || mkdir -p html
- $(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
+ $(XMLLINT) --nonet --xinclude --relaxng $(DOCBOOK_RNG) --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
--stringparam root.filename Linux-PAM_MWG \
--stringparam use.id.as.filename 1 \