aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_unix/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@suse.com>2023-01-31 11:41:28 +0100
committerDmitry V. Levin <ldv@strace.io>2023-01-31 10:41:28 +0000
commita44743a0bf50c8c6fedd8304524536aa040fd3b3 (patch)
treefb2812d7733ebb96018eb259f35f5890c6544066 /modules/pam_unix/Makefile.am
parentd13a8ea18f852e97201269e55255a14fe4fe5d0f (diff)
downloadpam-a44743a0bf50c8c6fedd8304524536aa040fd3b3.tar.gz
pam-a44743a0bf50c8c6fedd8304524536aa040fd3b3.tar.bz2
pam-a44743a0bf50c8c6fedd8304524536aa040fd3b3.zip
pam_unix: don't link against yppasswd_xdr if NIS is disabled
* configure.ac: Define HAVE_NIS if NIS is enabled. * modules/pam_unix/Makefile.am: Don't link against yppasswd_xdr.c if NIS is disabled. * modules/pam_unix/pam_unix_passwd.c: Don't redefine HAVE_NIS. Resolves: https://github.com/linux-pam/linux-pam/issues/523
Diffstat (limited to 'modules/pam_unix/Makefile.am')
-rw-r--r--modules/pam_unix/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/pam_unix/Makefile.am b/modules/pam_unix/Makefile.am
index 1658735b..74fc9b32 100644
--- a/modules/pam_unix/Makefile.am
+++ b/modules/pam_unix/Makefile.am
@@ -5,7 +5,7 @@
CLEANFILES = *~
MAINTAINERCLEANFILES = $(MANS) README
-EXTRA_DIST = md5.c md5_crypt.c lckpwdf.-c $(XMLS) CHANGELOG
+EXTRA_DIST = md5.c md5_crypt.c lckpwdf.-c yppasswd_xdr.c $(XMLS) CHANGELOG
if HAVE_DOC
dist_man_MANS = pam_unix.8 unix_chkpwd.8 unix_update.8
@@ -39,7 +39,10 @@ noinst_PROGRAMS = bigcrypt
pam_unix_la_SOURCES = bigcrypt.c pam_unix_acct.c \
pam_unix_auth.c pam_unix_passwd.c pam_unix_sess.c support.c \
- passverify.c yppasswd_xdr.c md5_good.c md5_broken.c
+ passverify.c md5_good.c md5_broken.c
+if HAVE_NIS
+ pam_unix_la_SOURCES += yppasswd_xdr.c
+endif
bigcrypt_SOURCES = bigcrypt.c bigcrypt_main.c
bigcrypt_CFLAGS = $(AM_CFLAGS)