aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_unix/Makefile.am
diff options
context:
space:
mode:
authorChristian Göttsche <cgzones@googlemail.com>2024-01-04 18:23:50 +0100
committerDmitry V. Levin <ldv@strace.io>2024-01-15 20:01:23 +0000
commitb430e2d1c93414cb14e9a3557ac895e864138497 (patch)
tree885eebd6d63d1bc048c9609a8f3d83df3c448788 /modules/pam_unix/Makefile.am
parent32112a7b6075e23d7acba37b9272be4a3926bd33 (diff)
downloadpam-b430e2d1c93414cb14e9a3557ac895e864138497.tar.gz
pam-b430e2d1c93414cb14e9a3557ac895e864138497.tar.bz2
pam-b430e2d1c93414cb14e9a3557ac895e864138497.zip
pam_unix: add audit support to unix_update(8)
Emit audit reports in the helper unix_update(8) about abnormal executions, unprivileged authentications, and password updates. Also log unprivileged authentication failures to syslog.
Diffstat (limited to 'modules/pam_unix/Makefile.am')
-rw-r--r--modules/pam_unix/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/pam_unix/Makefile.am b/modules/pam_unix/Makefile.am
index c510f87f..1780e586 100644
--- a/modules/pam_unix/Makefile.am
+++ b/modules/pam_unix/Makefile.am
@@ -74,7 +74,7 @@ unix_update_SOURCES = unix_update.c audit.c md5_good.c md5_broken.c bigcrypt.c \
passverify.c
unix_update_CFLAGS = $(AM_CFLAGS) @EXE_CFLAGS@ -DHELPER_COMPILE=\"unix_update\"
unix_update_LDFLAGS = @EXE_LDFLAGS@
-unix_update_LDADD = @LIBCRYPT@ @LIBSELINUX@
+unix_update_LDADD = @LIBCRYPT@ @LIBSELINUX@ @LIBAUDIT@
endif
if ENABLE_REGENERATE_MAN