aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorAndrey Kovalev <ded@altlinux.org>2024-10-18 10:25:17 +0300
committerDmitry V. Levin <ldv@strace.io>2024-10-18 08:00:00 +0000
commit43bdb7ce04c9cb00bdf0f5dda818b077b9dc7c56 (patch)
tree0bb54c65e292f5ab060968d5d1168f1d33a86953 /tests/Makefile.am
parent29c390c7e5c7ee12a1beebd7458aed2fcba53f91 (diff)
downloadpam-43bdb7ce04c9cb00bdf0f5dda818b077b9dc7c56.tar.gz
pam-43bdb7ce04c9cb00bdf0f5dda818b077b9dc7c56.tar.bz2
pam-43bdb7ce04c9cb00bdf0f5dda818b077b9dc7c56.zip
pam_get_authtok*: disallow setting pamh to NULL
This also prevents a potential NULL pointer dereference in pam_get_authtok_internal and pam_get_authtok_verify when the pamh argument they access is set to NULL.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d7462dea..7fb662e5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -13,7 +13,7 @@ TESTS = tst-pam_start tst-pam_end tst-pam_fail_delay tst-pam_open_session \
tst-pam_close_session tst-pam_acct_mgmt tst-pam_authenticate \
tst-pam_chauthtok tst-pam_setcred tst-pam_get_item tst-pam_set_item \
tst-pam_getenvlist tst-pam_get_user tst-pam_get_data tst-pam_set_data \
- tst-pam_mkargv tst-pam_start_confdir
+ tst-pam_mkargv tst-pam_start_confdir tst-pam_get_authtok
EXTRA_DIST = confdir