aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-03-12 08:36:42 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-03-12 08:36:42 +0000
commit993d5e30fa9085a05cc8231c49750e8bcc03170e (patch)
tree79d64253dd6290815a8a769267c0d34e7012a018 /tests/Makefile.am
parentbd940ba3beea685e297144705bc3d7547e81b837 (diff)
downloadpam-993d5e30fa9085a05cc8231c49750e8bcc03170e.tar.gz
pam-993d5e30fa9085a05cc8231c49750e8bcc03170e.tar.bz2
pam-993d5e30fa9085a05cc8231c49750e8bcc03170e.zip
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- Add lot of tests for make check
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..035a9cec
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,18 @@
+#
+# Copyright (c) 2006 Thorsten Kukuk <kukuk@suse.de>
+#
+
+AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include
+AM_LDFLAGS = -L$(top_builddir)/libpam -lpam
+
+CLEANFILES = *~
+
+TESTS = tst-pam_start tst-pam_end tst-pam_fail_delay tst-pam_open_session \
+ tst-pam_close_session tst-pam_acct_mgmt tst-pam_authenticate \
+ tst-pam_chauthtok tst-pam_setcred tst-pam_get_item tst-pam_set_item \
+ tst-pam_getenvlist
+
+check_PROGRAMS = ${TESTS} tst-dlopen
+
+tst_dlopen_LDADD = -L$(top_builddir)/libpam -lpam -ldl
+