aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a33d3d8d..be7da35f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,7 +4,8 @@
AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
-I$(top_srcdir)/libpam $(WARN_CFLAGS)
-LDADD = $(top_builddir)/libpam/libpam.la
+LDADD = $(top_builddir)/libpam_internal/libpam_internal.la \
+ $(top_builddir)/libpam/libpam.la
CLEANFILES = *~
@@ -18,4 +19,4 @@ EXTRA_DIST = confdir
check_PROGRAMS = ${TESTS} tst-dlopen
-tst_dlopen_LDADD = -ldl
+tst_dlopen_LDADD = $(top_builddir)/libpam_internal/libpam_internal.la -ldl