aboutsummaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2023-04-27 17:18:36 +1200
committerChris Packham <judge.packham@gmail.com>2023-04-30 20:28:57 +1200
commitb646773ebbdb60b886c712d43d9af78a5ad5d5cf (patch)
tree75f8c7911e0df64b756818b717427e5394a5162f /packages/gcc
parent6b5604e89eec5f886a03c879a007a7e26d747210 (diff)
downloadcrosstool-ng-b646773ebbdb60b886c712d43d9af78a5ad5d5cf.tar.gz
crosstool-ng-b646773ebbdb60b886c712d43d9af78a5ad5d5cf.tar.bz2
crosstool-ng-b646773ebbdb60b886c712d43d9af78a5ad5d5cf.zip
gcc/12.2.0: Regenerate patches
Run the patches through ./maintainer/manage-packages.sh -P -s gcc-12.2.0 to mop up the fact that we'd ended up with two 0005 patches. Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch25
-rw-r--r--packages/gcc/12.2.0/0006-driver-Extend-getenv-function-to-allow-default-value.patch (renamed from packages/gcc/12.2.0/0005-driver-Extend-getenv-function-to-allow-default-value.patch)15
-rw-r--r--packages/gcc/12.2.0/0007-Add-newlib-and-picolibc-as-default-C-library-choices.patch (renamed from packages/gcc/12.2.0/0006-Add-newlib-and-picolibc-as-default-C-library-choices.patch)11
-rw-r--r--packages/gcc/12.2.0/0008-Support-picolibc-targets.patch (renamed from packages/gcc/12.2.0/0007-Support-picolibc-targets.patch)9
-rw-r--r--packages/gcc/12.2.0/0009-gcc-Allow-g-to-work-differently-from-gcc.patch (renamed from packages/gcc/12.2.0/0008-gcc-Allow-g-to-work-differently-from-gcc.patch)14
5 files changed, 21 insertions, 53 deletions
diff --git a/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch b/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch
index 4f155f61..113a982a 100644
--- a/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch
+++ b/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch
@@ -15,15 +15,13 @@ and stop.
Signed-off-by: Keith Packard <keithp@keithp.com>
---
- gcc/config.gcc | 48 ++++++++++++++++++++++++++++++++++++++++--------
- gcc/configure.ac | 4 ++++
+ gcc/config.gcc | 48 ++++++++++++++++++++++++++++++++++++++++--------
+ gcc/configure.ac | 4 ++++
2 files changed, 44 insertions(+), 8 deletions(-)
-diff --git a/gcc/config.gcc b/gcc/config.gcc
-index c5064dd3766..ddab68fbf8f 100644
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
-@@ -648,6 +648,8 @@ esac
+@@ -648,6 +648,8 @@
# Common C libraries.
tm_defines="$tm_defines LIBC_GLIBC=1 LIBC_UCLIBC=2 LIBC_BIONIC=3 LIBC_MUSL=4"
@@ -32,7 +30,7 @@ index c5064dd3766..ddab68fbf8f 100644
# 32-bit x86 processors supported by --with-arch=. Each processor
# MUST be separated by exactly one space.
x86_archs="athlon athlon-4 athlon-fx athlon-mp athlon-tbird \
-@@ -854,16 +856,16 @@ case ${target} in
+@@ -854,16 +856,16 @@
esac
case $target in
*-*-*android*)
@@ -53,7 +51,7 @@ index c5064dd3766..ddab68fbf8f 100644
;;
esac
# Assume that glibc or uClibc or Bionic are being used and so __cxa_atexit
-@@ -956,7 +958,8 @@ case ${target} in
+@@ -956,7 +958,8 @@
case ${enable_threads} in
"" | yes | posix) thread_file='posix' ;;
esac
@@ -63,7 +61,7 @@ index c5064dd3766..ddab68fbf8f 100644
;;
*-*-rdos*)
use_gcc_stdint=wrap
-@@ -1606,13 +1609,13 @@ csky-*-*)
+@@ -1606,13 +1609,13 @@
case ${target} in
csky-*-linux-gnu*)
@@ -79,7 +77,7 @@ index c5064dd3766..ddab68fbf8f 100644
default_use_cxa_atexit=no
;;
*)
-@@ -3065,7 +3068,7 @@ powerpc*-wrs-vxworks7r*)
+@@ -3065,7 +3068,7 @@
tmake_file="${tmake_file} t-linux rs6000/t-linux64 rs6000/t-fprules rs6000/t-ppccomm"
tmake_file="${tmake_file} rs6000/t-vxworks"
@@ -88,7 +86,7 @@ index c5064dd3766..ddab68fbf8f 100644
extra_objs="$extra_objs linux.o rs6000-linux.o"
;;
powerpc-wrs-vxworks*)
-@@ -5915,3 +5918,32 @@ i[34567]86-*-* | x86_64-*-*)
+@@ -5915,3 +5918,32 @@
fi
;;
esac
@@ -121,11 +119,9 @@ index c5064dd3766..ddab68fbf8f 100644
+ tm_defines="$tm_defines DEFAULT_LIBC=$default_libc"
+ ;;
+esac
-diff --git a/gcc/configure.ac b/gcc/configure.ac
-index 23bee7010a3..4fd41993b58 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -2481,6 +2481,10 @@ if { { test x$host != x$target && test "x$with_sysroot" = x ; } ||
+@@ -2481,6 +2481,10 @@
fi
AC_SUBST(inhibit_libc)
@@ -136,6 +132,3 @@ index 23bee7010a3..4fd41993b58 100644
# When building gcc with a cross-compiler, we need to adjust things so
# that the generator programs are still built with the native compiler.
# Also, we cannot run fixincludes.
---
-2.39.0
-
diff --git a/packages/gcc/12.2.0/0005-driver-Extend-getenv-function-to-allow-default-value.patch b/packages/gcc/12.2.0/0006-driver-Extend-getenv-function-to-allow-default-value.patch
index d0ac2cec..32341c48 100644
--- a/packages/gcc/12.2.0/0005-driver-Extend-getenv-function-to-allow-default-value.patch
+++ b/packages/gcc/12.2.0/0006-driver-Extend-getenv-function-to-allow-default-value.patch
@@ -34,15 +34,13 @@ existing usage.
Signed-off-by: Keith Packard <keithp@keithp.com>
---
- gcc/doc/invoke.texi | 18 +++++++++++-------
- gcc/gcc.cc | 10 +++++++++-
+ gcc/doc/invoke.texi | 18 +++++++++++-------
+ gcc/gcc.cc | 10 +++++++++-
2 files changed, 20 insertions(+), 8 deletions(-)
-diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
-index ff6c338bedb..38eeeb7174b 100644
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
-@@ -33776,17 +33776,21 @@ The following built-in spec functions are provided:
+@@ -33776,17 +33776,21 @@
@table @code
@item @code{getenv}
@@ -71,11 +69,9 @@ index ff6c338bedb..38eeeb7174b 100644
@item @code{if-exists}
The @code{if-exists} spec function takes one argument, an absolute
-diff --git a/gcc/gcc.cc b/gcc/gcc.cc
-index bb07cc244e3..930d9835768 100644
--- a/gcc/gcc.cc
+++ b/gcc/gcc.cc
-@@ -10194,12 +10194,20 @@ getenv_spec_function (int argc, const char **argv)
+@@ -10194,12 +10194,20 @@
char *ptr;
size_t len;
@@ -97,6 +93,3 @@ index bb07cc244e3..930d9835768 100644
/* If the variable isn't defined and this is allowed, craft our expected
return value. Assume variable names used in specs strings don't contain
any active spec character so don't need escaping. */
---
-2.39.0
-
diff --git a/packages/gcc/12.2.0/0006-Add-newlib-and-picolibc-as-default-C-library-choices.patch b/packages/gcc/12.2.0/0007-Add-newlib-and-picolibc-as-default-C-library-choices.patch
index e4805ae8..59169b70 100644
--- a/packages/gcc/12.2.0/0006-Add-newlib-and-picolibc-as-default-C-library-choices.patch
+++ b/packages/gcc/12.2.0/0007-Add-newlib-and-picolibc-as-default-C-library-choices.patch
@@ -5,14 +5,12 @@ Subject: [PATCH 6/9] Add newlib and picolibc as default C library choices
Signed-off-by: Keith Packard <keithp@keithp.com>
---
- gcc/config.gcc | 11 ++++++++++-
+ gcc/config.gcc | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
-diff --git a/gcc/config.gcc b/gcc/config.gcc
-index ddab68fbf8f..e294ff8fbc8 100644
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
-@@ -646,7 +646,7 @@ case ${target} in
+@@ -646,7 +646,7 @@
esac
# Common C libraries.
@@ -21,7 +19,7 @@ index ddab68fbf8f..e294ff8fbc8 100644
default_libc=""
-@@ -5932,6 +5932,15 @@ bionic)
+@@ -5932,6 +5932,15 @@
musl)
default_libc=LIBC_MUSL
;;
@@ -37,6 +35,3 @@ index ddab68fbf8f..e294ff8fbc8 100644
"")
;;
*)
---
-2.39.0
-
diff --git a/packages/gcc/12.2.0/0007-Support-picolibc-targets.patch b/packages/gcc/12.2.0/0008-Support-picolibc-targets.patch
index 01dbba87..776d9545 100644
--- a/packages/gcc/12.2.0/0007-Support-picolibc-targets.patch
+++ b/packages/gcc/12.2.0/0008-Support-picolibc-targets.patch
@@ -8,14 +8,12 @@ the newlib-based logic for other configuration items.
Signed-off-by: Keith Packard <keithp@keithp.com>
---
- gcc/config.gcc | 11 +++++++++++
+ gcc/config.gcc | 11 +++++++++++
1 file changed, 11 insertions(+)
-diff --git a/gcc/config.gcc b/gcc/config.gcc
-index e294ff8fbc8..06af4057079 100644
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
-@@ -1082,6 +1082,17 @@ case ${target} in
+@@ -1082,6 +1082,17 @@
;;
esac
;;
@@ -33,6 +31,3 @@ index e294ff8fbc8..06af4057079 100644
*-*-elf|arc*-*-elf*)
# Assume that newlib is being used and so __cxa_atexit is provided.
default_use_cxa_atexit=yes
---
-2.39.0
-
diff --git a/packages/gcc/12.2.0/0008-gcc-Allow-g-to-work-differently-from-gcc.patch b/packages/gcc/12.2.0/0009-gcc-Allow-g-to-work-differently-from-gcc.patch
index d84e52f3..5265c03a 100644
--- a/packages/gcc/12.2.0/0008-gcc-Allow-g-to-work-differently-from-gcc.patch
+++ b/packages/gcc/12.2.0/0009-gcc-Allow-g-to-work-differently-from-gcc.patch
@@ -13,16 +13,14 @@ check for IN_GPP to have alternate behavior.
Signed-off-by: Keith Packard <keithp@keithp.com>
---
- gcc/cp/Make-lang.in | 7 ++++++-
- gcc/gpp.cc | 21 +++++++++++++++++++++
+ gcc/cp/Make-lang.in | 7 ++++++-
+ gcc/gpp.cc | 21 +++++++++++++++++++++
2 files changed, 27 insertions(+), 1 deletion(-)
create mode 100644 gcc/gpp.cc
-diff --git a/gcc/cp/Make-lang.in b/gcc/cp/Make-lang.in
-index 2de4e47c659..39c659b9537 100644
--- a/gcc/cp/Make-lang.in
+++ b/gcc/cp/Make-lang.in
-@@ -68,7 +68,12 @@ CFLAGS-cp/module.o += -DMODULE_VERSION='($(subst -,,$(MODULE_VERSION))U)'
+@@ -68,7 +68,12 @@
endif
# Create the compiler driver for g++.
@@ -36,9 +34,6 @@ index 2de4e47c659..39c659b9537 100644
xg++$(exeext): $(GXX_OBJS) $(EXTRA_GCC_OBJS) libcommon-target.a $(LIBDEPS)
+$(LINKER) $(ALL_LINKERFLAGS) $(LDFLAGS) -o $@ \
$(GXX_OBJS) $(EXTRA_GCC_OBJS) libcommon-target.a \
-diff --git a/gcc/gpp.cc b/gcc/gpp.cc
-new file mode 100644
-index 00000000000..3cd7b45e808
--- /dev/null
+++ b/gcc/gpp.cc
@@ -0,0 +1,21 @@
@@ -63,6 +58,3 @@ index 00000000000..3cd7b45e808
+
+#define IN_GPP
+#include "gcc.cc"
---
-2.39.0
-