aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuca Dariz <luca@orpolo.org>2023-12-28 20:42:48 +0100
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2023-12-29 14:27:31 +0100
commit06885ceb139976763aa815dd5ff1d972cecea4c9 (patch)
tree4b81642c682a9d701e8fde0bab66981789210263 /configure.ac
parent4541faab2ec63444e5afdb1aa17b0cb6180a3d55 (diff)
downloadgnumach-06885ceb139976763aa815dd5ff1d972cecea4c9.tar.gz
gnumach-06885ceb139976763aa815dd5ff1d972cecea4c9.tar.bz2
gnumach-06885ceb139976763aa815dd5ff1d972cecea4c9.zip
USER32: change default to disabled and make it a general option
* configfrag.ac: add the global option USER32; although it makes sense for 64-bit versions only, it can be used by future 64-bit architectiures and not only x86_64. Also, change the default setting to be disabled; now that we have a working full 64-bit system, it makes sense to consider it the common choice. * x86_64/configfrag.ac: define the correct 32-bit cpu if USER32 is enabled. Message-ID: <20231228194301.745811-2-luca@orpolo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3665d47a..cadc33b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,6 +147,16 @@ AC_ARG_ENABLE([device-drivers],
[;;
esac]
+AC_ARG_ENABLE([user32],
+AS_HELP_STRING([--enable-user32], [enable 32-bit user space on a 64-bit kernel]))
+[if [ x"$enable_user32" = xyes ]; then]
+ AC_DEFINE([USER32], [], [enable 32-bit user on 64-bit kernel])
+ AM_CONDITIONAL([enable_user32], [true])
+[else]
+ AM_CONDITIONAL([enable_user32], [false])
+[fi]
+
+
# Platform-specific configuration.
# PC AT.