aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/0003-Use-C-14.patch
diff options
context:
space:
mode:
authorSebastian Ramacher <sramacher@debian.org>2024-12-29 12:50:37 +0000
committerSebastian Ramacher <sramacher@debian.org>2024-12-29 12:50:37 +0000
commit873c687c09e0a1a78a8f3601d31330ad1897e484 (patch)
treeff2fa2e2d27b55c002a6d46d50aab2c66e0bf21a /debian/patches/0003-Use-C-14.patch
parent395b1f6877fbc2666383f3428f17400c35aa52a4 (diff)
parentb9ae809f200982119d16ec9613f3db95eca923b9 (diff)
downloadlibgav1-873c687c09e0a1a78a8f3601d31330ad1897e484.tar.gz
libgav1-873c687c09e0a1a78a8f3601d31330ad1897e484.tar.bz2
libgav1-873c687c09e0a1a78a8f3601d31330ad1897e484.zip
Merge branch 'master' into 'scrub-obsolete'
# Conflicts: # debian/changelog
Diffstat (limited to 'debian/patches/0003-Use-C-14.patch')
-rw-r--r--debian/patches/0003-Use-C-14.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0003-Use-C-14.patch b/debian/patches/0003-Use-C-14.patch
new file mode 100644
index 0000000..a4f4e10
--- /dev/null
+++ b/debian/patches/0003-Use-C-14.patch
@@ -0,0 +1,21 @@
+From: Boyuan Yang <byang@debian.org>
+Date: Mon, 27 Nov 2023 23:08:49 -0500
+Subject: Use C++14
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e9bb9b0..abc3b41 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -16,7 +16,7 @@
+ cmake_minimum_required(VERSION 3.7.1 FATAL_ERROR)
+
+ # libgav1 requires C++11.
+-set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD 14)
+ set(ABSL_CXX_STANDARD 11)
+ # libgav1 requires C99.
+ set(CMAKE_C_STANDARD 99)