aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Schubert <schubi@suse.de>2023-01-26 16:20:07 +0100
committerDmitry V. Levin <ldv@strace.io>2023-02-07 08:00:00 +0000
commit96b70abec27356eba17ecc16d1c52e8cfa5c46cd (patch)
treef9f0043913373fd2cd78c310deeeb8ca182f3d14 /configure.ac
parent75dceba6f3bd3f3a24018a5352674606469106e3 (diff)
downloadpam-96b70abec27356eba17ecc16d1c52e8cfa5c46cd.tar.gz
pam-96b70abec27356eba17ecc16d1c52e8cfa5c46cd.tar.bz2
pam-96b70abec27356eba17ecc16d1c52e8cfa5c46cd.zip
build: use <vendordir>/security directory for installation if it has been set
Otherwise the corresponding files are still installed in /etc/security. * configure.ac (AC_SUBST): Add VENDOR_SCONFIGDIR. (AM_CONDITIONAL): Add HAVE_VENDORDIR. * modules/*/Makefile.am (secureconfdir): Set to VENDOR_SCONFIGDIR if HAVE_VENDORDIR has been set, otherwise to SCONFIGDIR.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 587be871..b595b53a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -549,10 +549,13 @@ if test -n "$enable_vendordir"; then
else
STRINGPARAM_VENDORDIR="--stringparam vendordir '$enable_vendordir' --stringparam profile.condition 'with_vendordir;with_vendordir_and_without_econf"
fi
+ VENDOR_SCONFIGDIR="$enable_vendordir/security"
else
STRINGPARAM_VENDORDIR="--stringparam profile.condition 'without_vendordir'"
fi
AC_SUBST([STRINGPARAM_VENDORDIR])
+AC_SUBST(VENDOR_SCONFIGDIR)
+AM_CONDITIONAL([HAVE_VENDORDIR], [test -n "$enable_vendordir"])
AC_ARG_ENABLE([openssl],
AS_HELP_STRING([--enable-openssl],[use OpenSSL crypto libraries]),