aboutsummaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2024-09-01 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2024-09-10 08:00:00 +0000
commit7fb6beed01bc1a59438b8b2a9b34b2dba296e553 (patch)
tree2f6ae951c4d94d331e29e348e6ffd9846687be33 /doc/meson.build
parentaa3e91322cbc651bb130ec8636b28d676979d4fe (diff)
downloadpam-7fb6beed01bc1a59438b8b2a9b34b2dba296e553.tar.gz
pam-7fb6beed01bc1a59438b8b2a9b34b2dba296e553.tar.bz2
pam-7fb6beed01bc1a59438b8b2a9b34b2dba296e553.zip
meson: build Linux-PAM using meson
On my non-representative hardware, the full build using autotools (./autogen.sh && CFLAGS=-O2 ./configure && make -j`nproc` && make -j`nproc` install) takes about 45 seconds. On the same hardware, the full build using meson (meson setup -Doptimization=2 dir && meson compile -C dir && meson install -C dir) takes just about 7.5 seconds.
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 00000000..afe15851
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,26 @@
+custom_man_xsl = custom_target(
+ 'custom-man.xsl',
+ input: 'custom-man.xsl.in',
+ output: ['custom-man.xsl'],
+ command: [
+ redir_exe,
+ '@INPUT@',
+ '@OUTPUT@',
+ 'sed',
+ 's+MAN_STYLESHEET+' + man_stylesheet + '+g'
+ ]
+)
+
+install_data(
+ 'index.html',
+ install_dir: htmldir,
+ install_tag: 'doc',
+)
+
+install_html = files('install-html.sh')
+
+subdir('man')
+subdir('specs')
+subdir('sag')
+subdir('adg')
+subdir('mwg')