aboutsummaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 00000000..afe15851
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,26 @@
+custom_man_xsl = custom_target(
+ 'custom-man.xsl',
+ input: 'custom-man.xsl.in',
+ output: ['custom-man.xsl'],
+ command: [
+ redir_exe,
+ '@INPUT@',
+ '@OUTPUT@',
+ 'sed',
+ 's+MAN_STYLESHEET+' + man_stylesheet + '+g'
+ ]
+)
+
+install_data(
+ 'index.html',
+ install_dir: htmldir,
+ install_tag: 'doc',
+)
+
+install_html = files('install-html.sh')
+
+subdir('man')
+subdir('specs')
+subdir('sag')
+subdir('adg')
+subdir('mwg')